“The type “object” is not assignable to the type “text / number”. Tutorial (Data 1/5 - Creating Data)

Hi very new here and to no-code in general.

Was going through the tutorial which has worked fine right up until now (I’m on Data 1/5 - Creating Data). It looks like some features have changed since then and the tutorial does not reflect that. I’m getting this error:

The tutorial shows this:

When I followed along in a probably newer version of Composer, it has an extra “object” value type added to it. I think that’s the cause of the incompatibility:

Seeing as I’m just following along on the tutorial, I really have no further insight as to how to fix it. I changed the value type to the only other option which is “icon”, and didn’t help either.

As a note, I re-attempted the tutorial a few times to make sure I wasn’t wasn’t missing something. Any help would be greatly appreciated.

Thank you!

Okay. Quick important things to understand.
You are creating a data record.
Each data record is an object. That might have several different properties.

Example: apple is a fruit, it is an “object” that has a ‘color’ property and a size and a lot of others. So going on this example sure You cannot say that “the color of an apple is the apple.” This is why an input cannot be connected with an object. I hope this is clear enough.

When You create a data resource you have ro create the schema for those data records. You have to define what properties the data records (objects) will have.

I do not remember the exact properties that are in the tutorial but You coukd simply add a new property: “reminderText” with the type of text.

So clear steps:

  1. Create a new data recource for on-device storage.

  2. In the bottom part where You see: “Add new property” add a new property: “reminderText”.

  3. Set the type of THIS “reminderText” property. (You basically never have to change the type of the data record, so You never have to do what You tried…)

  4. Save the resource and go back to the input binding screen.

  5. There should be another dropdown now, where You can choose the previously created “reminderText” property.

  6. Bind to that and You will get it working.

  7. Step read the documentation on the docs.appgyver.com website as that gives more understanding of the data records. And watch Youtube tutorials as well.

*Side note… This question is not at all “build issue” as that tag refers to issues when generating the final, completed app, so to avoid irrelevant content on the forum please be kind to remove that duplicate topic. With any further questions regarding this topic let’s talk here.

Glad to have You here and good luck with the platform. :tada::pray:t2::pray:t2: