Thought this was odd. App REQUIRES Mac with M1 chip

From the public list of Appgyver apps, I noticed this when trying to install “Lilica” on my desktop Mac, running v12 Monterey:
image

Certainly don’t want my app to only be usable on a brand new M1 laptop.
Whats up with dat?