Tip: How to get rid of Appgyver browser title and favicon on web apps

This only works if you are hosting the web app yourself. Open the zip file and navigate to the subfolders:

_next/static/chunks/pages

and locate the JavaScript file named “_app-########…”

Capture

Edit/Open this file and do a string search for “Appgyver” until you come to this string: “title”,null,“Appgyver”

Replace the word Appgyver with the name of your app (or whatever you want), save the file, and re-deploy your app. Now when you open your app you should see whatever you entered instead of “Appgyver” on the browser tab.

This worked for me using Firebase Hosting (free) to host my web app instead of Appgyver’s hosting…

3 Likes

Note you may need to clear your browser cache to see the change take effect.

Good job, i will try it soon!!

It still flashes “Appgyver” briefly for a split second before it changes to the custom app title, as i havent figured how to prevent that yet.

Im working on replacing the Appgyver favicon (browser icon) now…

Update: So I just recreated a new favicon.ico file and replaced the Appgyver one (in the root directory), re-deployed app and it worked (after clearing browsing cache/data)

Now my web app is fully branded to my app name & logo :smile:

2 Likes

Do you have any tips for the firebase hosting?

All I did was follow the instructions here: Inizia con Firebase Hosting  |  Firebase Documentation

2 main problems i ran into that weren’t really documented.
1.) Make sure you have a folder named “public” created in your root directory, and unzip the app zip into that. The ‘deploy’ function grabs all the files from there to upload to the Firebase host.

2.) From the command line (cli) use the ‘deploy’ function with “–only hosting” parameter, like this:

otherwise it caused me errors.

One disappointing thing I ran into is the URL gets created from whatever Firebase project ID name you created (which cant be changed). In my case i had named my project ID after the name of my business rather than the name of my app, so now the URL to my app is: https://gud-boi-multimedia.web.app, instead of what i would have preferred - https://praypals.web.app, so just be aware of that. Unless you have your own domain then this isn’t an issue for you.

If you have any other problems let me know, i’ll try to help but i am by no means an expert on this since I just learned today.

oh ok then from what i see, its not a step by step guide like you would have when hosting a file on hostgator for example…

Its like everything else in Firebase you have to piece together information from all over their docs just to do anything, its not all in one place. Luckily, I had already had Firebase tools installed and set up already from a long time ago, so all i had to do was run the Firebase Init, and connect it to my project.

Some good news. I discovered you can add additional “Sites” to your Firebase Hosting deploy, so instead of being stuck with a default [project ID].web.app URL, you can specify a custom name to use in place of [project ID].

You have to also edit the firebase.json file and add the ‘Site’:‘site name’ parameter, and modify the firebase deploy function → firebase deploy --only hosting:[site name] to target the new site.

So for instance, my app URL is now: https://praypals.web.app

I obviously missed that option earlier.