Tutorial Problem: can not create Record. Error: missing Employees record ID

Hi all,

I am new in Appgywer, I am learning follow the official tutorial. But I got stuck in Topic: Data → creating Data
Video Link: https://platform.appgyver.com/goals/createDataRecord/video?app_id=207901

I followed every step from the tutorial, but can not create the record.

I got the message from Alert: “Error: Missing Employees record ID”!!!

It is so weird, because “id” should created automatically, I have no place to create it

Do yo know what’s the problem?

Best
Conny

Do you use the client side offline storage or the cloud storage?

Hi Eike, thanks for the suggestion, I checked again, I choosed the client-side storage, so it goes wrong… :sweat_smile:

If I change to AppGyver Cloud Storage, then everything is fine.

Sorry for the disturb… :sweat:

Does it means, you can not use clientside storage to create record?

Using the client side storage, u have to set the id urself using the formular GENERATE_UUID()

2 Likes

Thanks Eike! this solves the problem! :smile:

Hi, I am having a problem, even using the AppGyver cloud storage… I have done the same tutorial and the todo example and the records just don’t get created.
I get a JSON error response from server saying: “User unauthorized”

How do I get authorized?

Thanks

according to this:
Stuck on Tutorial “Data - 1/5 Creating Data” - Question - AppGyver

it is currently bugged. If you dont want to wait for the fix you can go through the tutorials using the local storage

Just fyi, it’s fixed now. I tested it and it works for me using the AG cloud storage as described in the tutorial.

Thanks Sam and Eike, it works for my app as well!
This is great!