TypeError: Network Request Failed

Hi! I have been using appgyver succesfully for the last year, but now something very weird is happening, i’ve tried countless of fixes but nothing seems to work.

Basically: The app won’t connect to the internet, it won’t do any POST/GET requests, nothing. I have a log-in page that when you press “log in” it does a POST request to my JWT access code, gets the Bearer token and check credentials. This worked perfectly, but a month or so ago it just broke.

The webapp works fine, but the mobile preview and the installed apk just wont log in, throwing the error “TypeError: Network Request Failed -1”

This is a thread that might have a fix, but i’m not able to modify the files mentioned: javascript - React Native fetch() Network Request Failed - Stack Overflow

Please, any ideas on how to fix this?

App id: 549450

Just submitted a bug report: Rest API connection failed (Only mobile) | Voters | AppGyver Community Edition

Fixed:

Well, this was hard to fix, if anyone is having this problem, check your hosting, in my case i have one that uses Cpanel. Cpanel has a Security Module (ModSecurity), as soon as i deactivated this on the domain i have my API it started working again.

Probably some Firewall rule or something like that.

I’m encountering the same issue with Firebase authentication. The app doesn’t initiate any calls; it simply keeps spinning, and there’s no mobile data usage on Android.

Hello Tomas,

I’m trying to understand and fix this issue but in my case I use iOS and Android app with Xano as my backend, this issue happened using wi-fi and mobile network, any tips in this case?

Best regards

Joseph