Unable to create record(post) to Backend (Airtable)

Hi all,
I am running a REST API direct integration test to Airtable as a backend and manage to get response (status OK) for Get Collection(Get) and Get Record(Get). However, when I tried run a test for create record(Post), it failed to response with an error message, status 404 {“error”:“not found”}. Even, if I set a custom schema, it shows a same result. Does anyone having similar problem on this? I have read similar topics in the forum but unfortunately unable to follow through. Please help.



Hi!

I haven’t used Airtable, but after googling a bit I have a couple of suggestions:

Set the request body as

"fields": {
   "Menu": 
   "Price": 
}

Instead of just Menu and Price. Also I saw something about needing a content-type header in your request, I’m looking at this thread if it would be helpful.

The “fields” object must be sent as Cecilia described above, but you also need to send that with an Authorization Header. Since I used HTTP Requests for my Airtable POST it looked like this:
Capture

But if youre using REST API data configurator you can set the Authorization Header there as well.

1 Like

Hi Cecilia,
I managed to create a record to the backend by setting the body as per your suggestion. Thank you so much for the help!

Hi John,
Thank you for the advice. I have set custom schema by adding fields as an object with two properties (menu and price), set authorization header and managed to create/record the data to the backend. Tks so much!

1 Like

Greetings,
I do not want to open a new thread so i will try here. I am really struglling in setting up Create Record to Airtable. I have the Get Record and Get Collection already set up properly. Anybody has a turorial or description or something? I cannot make a succesful testing. And i am really missing the logic behind the custom schema for POST method to Airtable. Any help? I typically get 402 or 422 error codes while testing.

1 Like

i finally did it. You have to edit the HTTP header with label and key as Content-Type, and the value as application/json. Then change the schema to custom schema, with details containing your objects(named according to what you have in your table)

I feel like an idiot. I’ve tried everything mentioned in this thread, and elsewhere where I could find suggestions. I’m able to create a record in Firebase but not in Airtable. Get Record and Get Collection are working from Airtable, but not Create Record. I can create a record in Airtable via Postman, no problem.

Should I be able to run a Create Record “Test” in the data configuration section? That’s not working for me. (Though, again, it’s fine in Get Record and Get Collection."

I don’t know where to begin guessing what I’m doing wrong. Should I be doing this via the “Create Record” flow object? Via the “URL” flow object? I don’t know what else to try.

Please help!

After clicking the “Create” button, I get this error from the HTTP flow:
{“error”:{“type”:“AUTHENTICATION_REQUIRED”,“message”:“Authentication required”}}

Screenshots: (bearer key is bogus)



Okay, I figure it out. There should be NO SPACE between “Bearer key” and the actual key. :roll_eyes:

Bad:
Bearer key GbIpXSSfWjWdBm

Good:
Bearer keyGbIpXSSfWjWdBm

Hola MOHAMAD_ABU_BAKAR
Me encuentro con el mismo error en el momento de hacer el test con la direccion de airtable, quisiera saber si pudiste solucionarlo.

Gracias

I’m quite new to the platform. How do you set the request body in Appgyver? thx!!

Is this what you mean?

I kind of figured out, It might be for I’m using a free account in airtable.