Unable to upload photo to firestore cloud


Im new to AppGyver and i really love the approach of programming apps. I managed to set up the Firebase Connector. I can now use the “create Record” node to create a new record in my database. But now, I would like to upload a photo taken in my app.

At first, I used the take photo node to take a photo. The filepath is stored to the page variable “variable1”, which has the typ local fliesystem path. This works well. I testes this part by binding the Content of a Paragraph to variable1. After taking the photo, the text changes to a file path.

My problem start with the “Firebase Storage upload files” node from the marketplace. I bound variable1 to the path in the List of values:

I started the app on my android phone. Then I took the photo, and the filepath was stored to variable 1. After klicking on the upload button, nothing happens. No error, nothing.

Please be so kind and help me with this problem. This seems to be my only problem with my app. If I manage to solve this problem, my database app is (almost) ready to use.

Best wishes from Vienna,

1 Like

See the below


Thank you so much, it worked!
I do not quite understand why mimeType is not set by take photo node, because mimeType is one of the outputs?

Neither do I. I hope they fix it soon.

Thank you so much for mentioning this :smiley:
I have been scratching my head for so long. I tried converting the created and modified date as utc. Tricky thing is on web application a blank mime type works. And so for some reason I kept ignoring trying that out.
Thanks mate

You are most welcome!