Universal Design System released, any issues?

We released the new universal design system we’ve been working on just now to appgyver.com – if you have any issues, please comment with them below so we’ll get to sorting them out as soon as possible!

Please see the documentation for explanations of the changes – we are working on providing more documentation and videos on the topic!

2 Likes

Hi @Mevi,

Since your latest update to Appgyver (preview app and builds) there seem to be a bug with the button disable function but only for Android as IOS phones are still fine.

I have formulas setting the value of the disable button function and depending on if there is a value (image) to display, the button would either be working or disabled (true/false). This bug only happens when images are saved in local resource / properties but works fine if formulas refer to any variables.

These are some of the functions I have used, that used to work on both IOS and Android phones.

data.Favorites1.Rodents_Guide == " " or IF(data.Favorites1.Rodents_Guide == " ", true, false)

It is like the Android phone thinks there is always a value (image) saved, and therefore the formula doesn’t work anymore, but there isn’t anything saved. I have also checked in debugger and the property shows no value.

Dan
I-phone - with disable buttons


Android - same page, same formula

Hi! What’s the value that comes through the data when it should not show? My initial instinct that you should use IS_EMPTY(data.Favorites1.Rodents_Guide) instead to make it work more reliably.

Hi @Mevi

My instinct too, but that doesn’t work on either phones :thinking:
Strange, as it used to be fine.

Hmm, well, check the content of that value, is it " "? Is it undefined? Or something else? You can use ENCODE_JSON for that, for example.

Hi @Mevi

Tried that too and getting the result " " on both phones but as you can see, the buttons react differently. :thinking:
Android

I-phone

yes I’m sure the result is the same on both phones, what’s interesting is that it evaluates as something different. But this isn’t a bug brought on by the just-released change in Composer :sweat_smile: do you have another thread where we could discuss this or can you make one?

Next things I would try to figure out what exactly is causing this and to make it possible for us to fix this issue:

  • Take the formula around and try it in different places, e.g. button visibility, text visibility, does it start working once it’s not trying to disable the button?
  • Take a different formula and use it to disable/enable a button, and see if that works. Try e.g. with a different data variable property.
  • Take a different formula that also evaluates " " and see if that changes the situation. E.g. if a page variable value is " " etc.

Im confused how to do container background colors now. It looks like it restricts me to a few preset colors now.

Ok so it looks like you can create additional colors but they get literally Created and Added to the default Palette, but there is no way to edit or delete them once they get created? The more colors you make it just keeps adding them infinitely with no way to remove or change them? Please help me if Im wrong here.

Just to illustrate the dilemma. If I am wanting to create custom background colors, it wont let me delete or edit ones i create, so if i have to trial and error many times to get the color to appear how i want in the app, it means i have to keep creating new colors however many times necessary, and they just keep piling up with no way to remove the old ones. So in my example here, i have many duplicate colors named test and test2 that I cant get rid of now.

@Mevi I cant find the background color of a paragraph in the ‘style’ menu.
image

I have some custom selection buttons that no longer seem to work with the new update. Existing ones still work but when I edit, it loses the formula. And I no longer have access to change the formula for the existing ones.

I was using formulas to set the background color depending on the selected field value.

Here are 2 examples of how I was changing the background for a selected value (color or type) …

image

I tried to update the formula here … but doesn’t seem to work.

image

Here’s the formula that I tried …

Any suggestions on how to enable this in the new update?

So there’s no way to set container margins any more (space around outside)?

Hi there. How does “Stretch to viewport height” work now? Any blog post/manual about that? Thanks.

You have released the UDS that will have profound effects on existing application layout deseign. And yet, you have:

  1. Obviously not provided adequate QA to the system. For example, It is impossible to edit properties in composite components
  2. You have not provided a guideline to implement the new system on existing applications
  3. You have not published adequate release announcements and warning to the magnitude of the changes and their impact upon existing applications
  4. You have not released a Project Copy feature that would have allowed to create a backup of the project before attempting to adapt it to the new system

The result is a disastrous damage inflicted to applications that took months to implement.

What were you thinking???

4 Likes

I’m also trying to figure this one out. I can’t create 100% height on components now, seeing “Unsupported binding” each time (for both scrollviews and containers)

Not to pile on but I have to agree with the disappointing sentiment. This is a mess. A Big Mess. My app is huge with a lot of pages and countless containers that had precise positioning and margining which is all now messed up and is going to take countless days to go through and figure out how to correct everything.

Hey @Mevi,

I’ve sent a private message regarding a request for app cloning related to updates/glitches related to the new Universal Design System. :slightly_smiling_face:

Thanks,
Awesomeosep

Unfortunately the only thing I found is that my apps, the result of hours and hours of work, have become unmanageable with the new Universal Design System. For example, it is impossible to give percentage values to the heights, and now all the components are arranged at random.
Unfortunately, therefore, what I see now is that all the hours used for my projects have been lost, with major work problems because some apps were still in construction.
This is my Universal Desperation Situation!

@Roberto_Calcagno
@Mevi

Yes. Going through and fixing everything this morning and also found that ‘Set Height’ cannot be set to a percentage.

Roberto, we worked around this issue by setting a formula to: “100%” - Whilst this complains its invalid, it still actually sets and works.