Unknow error trying to upload files

Hi Appgyver team!

I am facing an issue which I have been trying to solve for the past week.
My app id is 186727
and the problem is in the webview component and the error is produced at “Upload Files”.

Could you please help me have a look at my app and see why my photo taken from the camera could not be uploaded? Please press the + icon on the bottom nav bar to trigger the native camera.
I think I have got the bucket URL correctly, not sure why the photo wouldn’t be uploaded. Eventually, I would love to create a record based off the uploaded pic and fetch it to my bubble.io database.

Thanks a lot!!!

Hi Jasper, welcome to the community! I took a look at your app and seems like you had a couple of unnecessary steps between Take photo and Get Bucket Upload URLs, maybe something was going wrong with the files there. I created a similar, working implementation of upload files in parallel to your flows, hope that helps you move forward with your app. :slight_smile:

Hey Mari!

Thanks so much - it worked!

May I please ask how I could get access to the database and see all the records?? Is there an interface for that?

Also, I have an API for bubble.io app, the API works in test but when I do it with “create record” logic, it doesn’t work - could you please help me have a look as well?

Thanks so so much for your help!!!

Best
Jasper

Hey Jasper,

I figured out the issue – outputs["Get bucket upload URLs"].files is an array, so you need to pick the first object inside the array to be able to access the upload URL. With this formula it works:

image

The way the image storage works is that you have a storageKey for each hosted file that you can use in the “Get bucket download URLs” flow to get a temporary download URL for the image. They don’t have any permanent URLs, so you have to get the bucket download URLs each time you want to view the images – the storageKey is the only persistent way to access them.

Hey Mari

Thanks so so much! It worked like a charm!

Best
Jasper

1 Like