Unknown error, contact support for more details on Android package

Hello. I created simple app and trying to export it to android buld.
I have error message: “Status: error
Message: Unknown error, contact support for more details.”

This error message nead info about how to contact support. I Try all the website and not see any clear support form or contact info.
Plese help with that error. I dont know what is the problem. I Try few times with difrent client runtime versions.
I created my keystore fille in Android Studio, also other version for testing in KeyStore Explorer. Error is alwys that same message “unknow error”. I dont know what im doing wrong.

I am facing the exact same problem, I have tried to build my to-do app 3, no 4 times today.

Please share any resource/ guide that you get, I am also a newbie of the non-tech variety and this is my first project to feel the whole process.

Good luck mate.

1 Like

Same here! I’m also getting the “contact support” error message. My previous build from yesterday worked flawlessly, but today I’ve tried 3 or 4 times. It just keeps failing. I made my keystore file with the Command Prompt, and this has worked for me before…

I went ahead and contacted support, will share here if they suggest any fixes that may benefit everyone here. Also, how can I access the error log of the failed build? This could contain info that could help me resolve this issue. I see many people say “view the error log” but I can’t find an error log!

2 Likes

Me neither. There is literally no error log I could use to trace my mistake.

You mentioned that your previous build work… Can you kindly share your steps or correct my own steps? This is my first build and I am not sure if I had missed any steps.

Here is what I did in order. This is for the “Android Mobile/Tablet”.

  1. Clicked “Configure”

  2. Uploaded the Keystore file I created with Oracle JDK 15, through my terminal

  3. Filled in the following according to the documentation instructions: “Keystore password”; “Keystore alias”; “Keystore alias password”.

  4. Filled in my “Display Name” as “todo”, “Lock Screen Orientation” as “Portrait” and my URL Scheme as “todo”. I had seen someone do something familiar on the forum.

  5. Created and uploaded PNG files that corresponded to the size requirements of the Icons and Splash Screens. I did not do that for the notification icons because I did not create any push notification.

  6. I did not do anything in the “permissions” for the aforementioned reason and simply clicked “save & next”.

  7. Clicked “build”, choose the 2.5.12 runtime version. Made my version code 1001 and version name 1.0.2. It was initially 1.0.1, but I have done this process over 6 time already today and used all the “Client Runtime Version” through my different trials that I thought I should change it up.

Speaking of which, do you know any resource that explains the meaning of the “Client Runtime version”?

  1. I clicked “build”, and waited for about 20 minutes before receiving a heartbreaking error.

Have I missed anything?

Sure thing! I’ll share everything I did for when it worked:

  1. Just like you, I clicked “Configure”. So far so good.

  2. Next I uploaded my keystore file, just like you did. My keystore file was created with Oracle JDK 11, through my Command Prompt (cmd). This is a bit old, now that I think of it. Maybe it could be my problem? I’ll try this again tomorrow with an updated JDK version, version 15 is recommended.

Anyway, to generate my keystore file, I pasted this into my Command Prompt:

keytool -genkey -v -keystore my-app-name.keystore -alias my-app-name -keyalg RSA -keysize 2048 -validity 10000

That is what the AppGyver Docs instructed me to paste into the Command Prompt, you can view the page telling you to do this here:

https://docs.appgyver.com/publishing/build-service/android-builds

So I pasted that into the Command Prompt. Then I changed both texts “my-app-name” into my app’s name. To keep things simple I changed them both into the same value, however, I think the first value is the keystore name and the second one is the keystore alias. But yes, I changed them both to the same value to make it easier for me.

Then I ran the command, and when it asked for a keystore password, I created a password, and hit enter. It asked to retype the password, so I did and hit enter.

I left all the other options (like: name, city, city code etc.) blank, I just hit enter to give them a blank value. Lastly, it asked me if the settings were correct and I typed “yes” and hit enter. The keystore file was saved on my computer.

  1. Just like you, I typed in my values on the page. At “Keystore password” I typed in the password I created for the keystore (needs to be the same one as you entered when creating the keystore). At “Keystore alias” I typed in the value that I entered in the place of “my-app-name” when I created the keystore. At “Keystore alias password” I typed in the same password as “Keystore password”.

Since I used the same values for “my-app-name” and the keystore password, it was easier to remember, and I just had to type the same value everywhere. You can try this to make it easier for you.

  1. I also filled in my display name with my name, and lock screen orientation as portrait. I left the “URL Scheme” blank, since I didn’t know what to enter.

  2. I didn’t have any PNG files to upload, because I was just testing my app, so I left them all as defaults.

  3. At “permissions” I just selected two permissions, “read storage” and “write storage” as I needed this functionality for my app. If you’re unsure what to select, maybe just select all the permissions? Maybe that could work? :slight_smile:

  4. I chose the latest runtime (one on the right) and clicked “build”. My version code was simply 1 and my version name 1.0.0.1. And then, 30 mins later, I got an email saying my build was successful and it had a link for me to download the APK (app file).

I don’t know what the “client runtime version” is or what it does.

From what it looks like to me, we did all the same steps. Maybe just make sure you enter the correct values for “keystore password” and “keystore alias” and “keystore alias password”. They should be the same values you entered when creating the keystore file. That was one mistake I made when building my first build. This is only my second build, so I’m not an expert. I’m also very new to AppGyver and the build process is quite complicated.

When I did everything like that, it worked. So I updated some things in my app and then when I tried to build again, I got an error. I retried on different keystore files and different “client runtime versions” but it kept failing, so I created this post on the forum.

I don’t know what went wrong, it looks to me like we did all the same steps. Sorry for the long answer. Please tell me if there is anything else you would like to know. Greetings!

Thanks guys for sharing all the steps you take.

For the start sorry for my english. Its not my native language and i’m writing this being little tired right now…

I must admit, im bit angry right now. I speand a lots of time to learn and buld my app with AppGyver and im apricie this tool is free for small developers like me. I whas so happy with result and having my first app i need working on test envarmant. So cool.
But failing this tool on final step makes me sad and angry. I Read all what I find, and bigest problem - there is no actual replay and any help from “suport”. There is no suport at all. No cear link and form how to contact support etc. I make forum post, I sendbug report info. Nothing.

Lik I describe before, my bigest suspect was keystore file (rest of it sems absolutly simple and easy) I use 2 tools to generate it and one of it is official Android program - Android Studio. Its easy to understand and no reason to give broken keystores.

On the official page its sugestion to use JDK 15, not JDK16… Ok so provide any link to this plese. Your official link show JDK16. I fund som JDK15 but for me is not possible to understand how properly use it right now. Its archaic tool with loots of manual editing as far i can see to even isntal it and start command line.

Sor until devs are not responds I have small ask - can somone ceate keystonre in JDK15 for me and seend it here for dowland? I will just use it for test if this is the problem not reciving proper working buld. Thanks.

Thank you for expressing your concerns. I think we’re all in the same shoes now. I also suspect that my keystore file is the problem. Maybe it has to do with my JDK installation?

I am going to try to create a new keystore file on a different PC with Oracle JDK 15. If the build is successful, and I know for sure that the keystore file is working, I will provide a link for you to download the working keystore file and give you the info to use it to test your builds, until support can help us officially resolve this issue.

I’ll try that right away. I’ll keep you updated.

Thank You very mutch JP_van_der_Merwe, i’m looking forward for the results of your experiment and for the keystore file.
I’m appreciating your help and input.

1 Like

It’s my pleasure. I just did a fresh JDK 15 install and created a keystore file, and uploaded it to a test build. I’ll let you know when I get the email stating if the build was successful or failed.

Ok, so I just got an email: the build failed! It’s very unfortunate, but I have 2 plans:

  1. I’m going to try building the app again with the same settings and keystore but on different “client runtime” versions.
  2. I’m going to test the keystore file on a different, very simple project, to see if it may be my app that is causing the error.

Don’t worry. It’s not an issue with your keystore or any of the setting. A lot of other users are unable to build their app even though that can build just fine a few days ago.

AppGyver itself is having problems with their build system. Everyone is unable to build anything at the moment using any framework or for any platform

We’ll just need to wait for them to repair the issue.

1 Like

Ok in the mentime I up with similiar idea like JP_van_der_Merwe, and i created new empty app, just a simple paragraph of text and I try to use my keystore. Result is that same - unknown error.

Now, that still not provin the problem is in ours keystores. Maybe just all system is broken now and its not our foult at all.

Update: Thanks Izzuddin_Yussof, that what I was thinking right now.

1 Like

Well then I guess that solves our problem! Thank you everybody, I guess we’ll just wait for an update from AppGyver. :slight_smile:

1 Like

@JP_van_der_Merwe,

Thank you very much for your response.

@jakubus, @Izzuddin_Yussof , it is so weirdly comforting to know that we are not alone on this. I will follow your advice and wait for two-three days before building again.

I also have the same problem and some days any .keystore file is never good (I use “keystore explorer”, it’s free and until a few days ago it always worked well for the appgyver build.
Let’s wait together for the appgyver staff to communicate something to us.
It would be a good thing for the AppGyver staff to make a video, where they show all the steps. In particular the steps after, when you load the APK on the goggle Play Console and it replies that the “signature is not valid”. Then I can’t go on anymore and I don’t know what to do.

Peace to APPGYVER and everyone

Indeed. Is there any way we can request from the AppGyver staff to make such a video? Maybe after they determine what is currently wrong with the build system.

Yes, that is all we can currently do. Thank you everyone.

Same here with android build. Wait for appy gyvers response. Thanks.

1 Like

Hey guys ! Now BUILD works !
Now BUILD works
I load APK on goggle play console and it tells me that the signature is not valid.
Which .keystore file do I need to upload to have APK that works? . The “first” “historical” .keystore file or the last one I made today?
A little help?

I have no idea. I have never uploaded an APK to the Play Store. Should we try to ask support?