Very strange build error on iOS only - "No space left on device"

I’m getting the same problem today!
The three options of runtime available are still gettin this error!

I have same problem now - 2023, May 10
Versions 4.6.36, 4.7.36, 4.7.37 - all build this same error. Fix please ASAP

1 Like

same problem for me pls help me bro

Hi, bro

This problem is resolved if on your computer will be such operating memory. I think AppGyver use your computer’s memory for compilation file for iOS AppStore.

Best regards

I’ve the same problem now on 2 different PC’s that previously worked fine!

I think AppGyver use your computer’s memory for compilation file for iOS AppStore.

This is not true, AppGyver does not use any of your computer’s resources to build your application. After submitting the build, you can even turn off your computer and you’ll still get the result. The “out of memory issue” is on our end, and we are looking into fixing it as soon as possible.

Thank you Kirill for your comment.

Maybe my experience help you and AppGyver team find the resolve this bug.

I tried to build app and on my iMac, where I have some problem with memory, and get error in build app for iOS.

Than I tried build app on my MacBook with enough memory and build is created success.

That seems to be just a coincidence :slight_smile: As said, AppGyver does not use your computer’s resources to create a build.

Hi everyone,

This has been fixed. All iOS builds should operate normally.

1 Like

Hello, with iOS I am also receiving: “ENOSPC: no space left on device, write”.
Thanks in advance

Hi, I also had this issue today with my build Build 525081


Installing ReactNativeExceptionHandler (2.3.0)
Installing TOCropViewController (2.6.1)
Installing Yoga (1.14.0)
Installing boost (1.76.0)
――― MARKDOWN TEMPLATE ―――――――――――――――――――――――――――――――――――――――――――――――――――――――――――



Errno::ENOSPC - No space left on device - fcopyfile

same error happen now in 2023 june 10

I thought this was temporary so yesterday I tried and I tried today again and got the same error message

@Kirill_Leventcov just wanted to share the specific error message I get, I created a copy of the project and deleted all other projects that I had that had compiled versions and still get an error message for IOS

Runtime version: 4.7.37;
AB version: 1.7.11

ASSETS_ARCHIVE_URL=""%3B%20filename*%3DUTF-8’' npxrnv export -p ios -s standalone_appstore -c standalone --ci --yes --skipRnvCheck --packageManager yarn --template @appgyver/orchestra-template-standalone@4.7.37 -r --xcodebuildArchiveArgs “OTHER_CODE_SIGN_FLAGS="–keychain\ AppGyver-675450"”


│ [ error ] [configure] ENOSPC: no space left on device, write
Error: ENOSPC: no space left on device, write
at Object.writeSync (node:fs:920:3)
at Object.writeFileSync (node:fs:2208:26)
at fsWriteFileSync (/private/var/folders/jr/8x2sjv2d26d6wcx1dxmb_yqc0000gn/T/675450-ios-285305/node_modules/rnv/src/core/systemManager/fileutils.js:20:8)
at writeCleanFile (/private/var/folders/jr/8x2sjv2d26d6wcx1dxmb_yqc0000gn/T/675450-ios-285305/node_modules/rnv/src/core/systemManager/fileutils.js:138:28)
at /private/var/folders/jr/8x2sjv2d26d6wcx1dxmb_yqc0000gn/T/675450-ios-285305/node_modules/@rnv/sdk-apple/src/podfileParser.js:177:5

yeah same happen bro until now bro

please appgyver fix this strange error I hope.

This is still happening. Could you please look into it? @Kirill_Leventcov


We are looking into this.


The issue has been fixed.

1 Like

ok bro I can testing it.