Web app build error

Hi,

Desperately need some help. I keep getting the following build error.

Version: 1.9.22
Status: error
Message: Unknown error, contact support for more details.

I’ve attached the log file - can anyone work out why the app is fine in preview but when I try and publish it does not work.

I’ve tried twice now as two seperate projects and cannot get it to build.

Build 280134 / https://platform.appgyver.com/builder/applications/177909/

I’ve attached the log file.

Many thanks,

Dom151344-error.log (303.7 KB)

Hi! Are you still getting the same error? From the error log, it looks like a problem with one or more images in your app, and I think we fixed one problem there, so maybe it works for you now?

I am getting the same issue since yesterday.
My builds are failing for 1.9.22 with same message.
Build with Beta works but result is crap, probably as my components are not on Beta.
Any idea how to solve this?

Hi, 1.9.22 has the image url issue, so you would have to check through all your assets in the app that all the urls you are using are secure and working. This issue is fixed in 2.4.16 and later. Can you report more exactly on what your bugs on the beta is, so that we could fix them?

Hi Mevi,

So I just tried the rebuild using 2.4.17 and its working, at least the build isn’t failing. The app runs which is great, however, now the container with the repeated object is not appearing. Do I need to use a new container object to fix this issue?

I updated all the components to the new version in the component library but I didn’t delete the old container object and replace it with the new one in the app itself.

What do you think?

Cheers,

Dom

Hi! There shouldn’t be anything specific that you’d need to update for a simple Container to work, so it depends on what your logic is like to make it appear, or is it just on the page but not showing? Check against preview-beta.appgyver.com to be able to more quickly ascertain what’s going on, is the data appearing that you need etc. 2.4.17 treats web stack differently than 1.9.22, as explained here, so please check that as well.

Thanks Mevi – I’ll look into the web stack as you suggest and get back to you.

Hey,

I removed all images and it still does not work, so I dont this this is it…
For the issue in Beta:
I attached the log file with the errors. It looks like _next is search at the top level e.g. localhost/_next/ while my application including all folders is one level below: localhost/students/index.html .

Best,
jo
localhost-1607698313787.log (4.7 KB)

Hmm, alright, I have no more ideas :sweat_smile: Can you send me a direct message with your app id so that I can get this looked at more in depth?

Hi Mevi,

Sorry for taking so long to reply – I was waiting for new version of AppGyver build to be complete.

So I’ve tried to rebuild the app in the new version to see if the problem has gone away. It hasn’t. I don’t think it’s an issue with loading graphics, as I haven’t done that in this version. All I do have is a dummy login screen which has a button that opens the Agencies screen. Here there is a data source which is calling the API and returning some data. I’m then using a container and using the repeat function to display just one field (Agency Name) from the returned data.

When setting up the data source, everything is OK (using test functions in data source to retrieve data). When I run the app in the web preview, everything also runs ok, and the agency names are displayed correctly. See screenshot below.

When I then compile for the Web App, something is going wrong. I’ve used version 2.4.25 of the build service.

The app ID is 185494 (https://platform.appgyver.com/builder/applications/185494/pages/3), /pages/3 is where I assume the compiler doesn’t like something. Please try the preview (https://preview.appgyver.com/287719/rental-heroes-admin-2/page.Page3) – its basically doing nothing other than repeating the name so I’m at a loss as to why this causing the build to fail.

Any assistance to resolve this issue would be much appreciated, we are so behind on this project now due to this continual problem.

Cheers,

Dom

Hi! Currently the web app compilation has some issues (in 2.4.24 and 2.4.25) which should hopefully be fixed in the next version. We were unable to fix it with the reduced team we had over the holidays, but now that we are returning back to work it should be fixed quickly.

Thanks Mevi,

Will you be able to advise when the new version is released so I can retest?

Cheers,

Dom

Hi! I’ll let you know here when it’s out. I’m expecting it for this week, unless this issue is larger than we know of at the moment.

Hi Mevi,

I hope all is well. I noticed you released a new version and with build 2.4.26 I can finally get the web app published, which is great news!

There is however still a bug, I was trying to publish to an existing domain and the build is picking up the login screen from a previous build – the current start screen just has a button whereas after the build, I was still seeing username and password fields from a previous build. It looks like its not clearing out all the old data for some reason.

When I change the domain, I just added a 1 to the end, the build was expected and is fine as a temporary workaround.

Also, in relation to this, do you have an option to clear out existing builds from hostnames, it’s starting to get messy now with multiple versions, not sure what people will be able to see if they come across the right address, etc. it’s a bit of a security risk.

Cheers,

Dom

Hmmmm I thought we had that cache issue fixed, but I’ll check this out. Perhaps we hadn’t tested it with an app where there is authentication, and the case is different there :frowning: However, even with the bug the newer version will appear in 24 hours.

As for clearing out existing builds, we don’t currently have anything except 1. you building a blank page on top of that address or 2. you send an email to contact@appgyver.com asking us to remove them.