Web Build failing due to ESOCKETTIMEDOUT

Hi,

The builds are taking more than 1hr 30mins which used to take only 20 mins before for the same app. After such long time its resulting into error as shown below:

App Ids : 435900, 435936, 439303
Runtime Version: 4.5.10

Runtime version: 4.5.10; AB version: 1.7.6 COMMAND: ASSETS_ARCHIVE_URL=https://appgyver-meap-assets.s3.amazonaws.com/lyps060or3rxj38hbutte8nvvqew?response-content-disposition=attachment%3B%20filename%3D"assets.zip"%3B%20filename*%3DUTF-8’'assets.zip&response-content-type=application%2Fzip&X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAJJSXXQRL4UNGBAXQ%2F20220902%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20220902T080648Z&X-Amz-Expires=172800&X-Amz-SignedHeaders=host&X-Amz-Signature=6ed9b8ded6ecadd51bad77b698c64a1d9af227d2d6749757342f8c1f791208ff NODE_OPTIONS=–max-old-space-size=8096 dockerrun --rm -v /tmp/538515-web-241609:/app:z -v /home/ec2-user/.npmrc:/home/node/.npmrc web ash -c ‘NODE_OPTIONS=“–max-old-space-size=8096” NEXT_SUPPORT_RELATIVE_PATHS=true ASSETS_ARCHIVE_URL=“https://appgyver-meap-assets.s3.amazonaws.com/lyps060or3rxj38hbutte8nvvqew?response-content-disposition=attachment%3B%20filename%3D"assets.zip"%3B%20filename*%3DUTF-8’'assets.zip&response-content-type=application%2Fzip&X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAJJSXXQRL4UNGBAXQ%2F20220902%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20220902T080648Z&X-Amz-Expires=172800&X-Amz-SignedHeaders=host&X-Amz-Signature=6ed9b8ded6ecadd51bad77b698c64a1d9af227d2d6749757342f8c1f791208ff” npx rnv export -p web -s standalone -c standalone --ci --yes --skipRnvCheck --packageManager yarn --template @appgyver/orchestra-template-standalone@4.5.10 -r’ FAILED with ERROR: FAILED with ERROR: error An unexpected error occurred: “https://registry.yarnpkg.com/next/-/next-12.1.0.tgz: ESOCKETTIMEDOUT”. info If you think this is a bug, please open a bug report with the information provided in “./yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… warning mini-css-extract-plugin@0.4.3: Invalid bin field for “mini-css-extract-plugin”. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/next/-/next-12.1.0.tgz: ESOCKETTIMEDOUT”. warning mini-css-extract-plugin@0.4.3: Invalid bin field for “mini-css-extract-plugin”. warning mini-css-extract-plugin@0.5.0: Invalid bin field for “mini-css-extract-plugin”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info If you think this is a bug, please open a bug report with the information provided in “./yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/next/-/next-12.1.0.tgz: ESOCKETTIMEDOUT”. warning mini-css-extract-plugin@0.4.3: Invalid bin field for “mini-css-extract-plugin”. warning mini-css-extract-plugin@0.5.0: Invalid bin field for “mini-css-extract-plugin”. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field “@jridgewell/gen-mapping@0.3.1” is incompatible with requested version “@jridgewell/gen-mapping@^0.1.0” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.10” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.6” error An unexpected error occurred: “https://registry.yarnpkg.com/next/-/next-12.1.0.tgz: ESOCKETTIMEDOUT”. warning mini-css-extract-plugin@0.4.3: Invalid bin field for “mini-css-extract-plugin”. warning mini-css-extract-plugin@0.5.0: Invalid bin field for “mini-css-extract-plugin”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info If you think this is a bug, please open a bug report with the information provided in “./yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… at makeError (./node_modules/execa/lib/error.js:60:11) at handlePromise (./node_modules/execa/index.js:118:26) at runMicrotasks () at processTicksAndRejections (node:internal/process/task_queues:96:5) Seems like your node_modules is corrupted by other libs. ReNative will try to fix it for you [ task ] [install] cleanNodeModules[1] [ error ] [install] COMMAND: yarn FAILED with ERROR: error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field “@jridgewell/gen-mapping@0.3.1” is incompatible with requested version “@jridgewell/gen-mapping@^0.1.0” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.10” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.6” error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… at makeError (/app/node_modules/execa/lib/error.js:60:11) at handlePromise (/app/node_modules/execa/index.js:118:26) at runMicrotasks () at processTicksAndRejections (node:internal/process/task_queues:96:5) [ error ] [install] COMMAND: yarn FAILED with ERROR: error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field “@jridgewell/gen-mapping@0.3.1” is incompatible with requested version “@jridgewell/gen-mapping@^0.1.0” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.10” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.6” error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… at makeError (/app/node_modules/execa/lib/error.js:60:11) at handlePromise (/app/node_modules/execa/index.js:118:26) at runMicrotasks () at processTicksAndRejections (node:internal/process/task_queues:96:5) ┌──────────────────────────────────────────────────────────────────────────────┐ │ :rocket: SUMMARY | 9/2/2022, 9:35:09 AM │ FAILED with ERROR: error An unexpected error occurred: “https://registry.yarnpkg.com/next/-/next-12.1.0.tgz: ESOCKETTIMEDOUT”. info If you think this is a bug, please open a bug report with the information provided in “./yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… warning mini-css-extract-plugin@0.4.3: Invalid bin field for “mini-css-extract-plugin”. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/next/-/next-12.1.0.tgz: ESOCKETTIMEDOUT”. warning mini-css-extract-plugin@0.4.3: Invalid bin field for “mini-css-extract-plugin”. warning mini-css-extract-plugin@0.5.0: Invalid bin field for “mini-css-extract-plugin”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info If you think this is a bug, please open a bug report with the information provided in “./yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/next/-/next-12.1.0.tgz: ESOCKETTIMEDOUT”. warning mini-css-extract-plugin@0.4.3: Invalid bin field for “mini-css-extract-plugin”. warning mini-css-extract-plugin@0.5.0: Invalid bin field for “mini-css-extract-plugin”. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field “@jridgewell/gen-mapping@0.3.1” is incompatible with requested version “@jridgewell/gen-mapping@^0.1.0” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.10” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.6” error An unexpected error occurred: “https://registry.yarnpkg.com/next/-/next-12.1.0.tgz: ESOCKETTIMEDOUT”. warning mini-css-extract-plugin@0.4.3: Invalid bin field for “mini-css-extract-plugin”. warning mini-css-extract-plugin@0.5.0: Invalid bin field for “mini-css-extract-plugin”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info If you think this is a bug, please open a bug report with the information provided in “./yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… at makeError (./node_modules/execa/lib/error.js:60:11) at handlePromise (./node_modules/execa/index.js:118:26) at runMicrotasks () at processTicksAndRejections (node:internal/process/task_queues:96:5) Seems like your node_modules is corrupted by other libs. ReNative will try to fix it for you │ [ error ] [install] COMMAND: yarn FAILED with ERROR: error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. Error: Command failed with exit code 1: yarn warning package.json: No license field warning No license field warning Resolution field “@jridgewell/gen-mapping@0.3.1” is incompatible with requested version “@jridgewell/gen-mapping@^0.1.0” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.10” warning Resolution field “@babel/types@7.17.12” is incompatible with requested version “@babel/types@^7.18.6” error An unexpected error occurred: “https://registry.yarnpkg.com/date-fns/-/date-fns-2.29.2.tgz: ESOCKETTIMEDOUT”. yarn install v1.22.15 [1/4] Resolving packages… [2/4] Fetching packages… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info If you think this is a bug, please open a bug report with the information provided in “/app/yarn-error.log”. info Visit yarn install | Yarn for documentation about this command. info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… info There appears to be trouble with your network connection. Retrying… at makeError (/app/node_modules/execa/lib/error.js:60:11) at handlePromise (/app/node_modules/execa/index.js:118:26) at runMicrotasks () at processTicksAndRejections (node:internal/process/task_queues:96:5) │ │ └──────────────────────────────────────────────────────────────────────────────┘

I’m getting the same error now. Were you able to find out what is causing this?

No. I couldn’t find any fix

In case your app is stuck in “queued” status still, please send me your App ID.