Work on an app.. akl is good, then BOOM - red screen on iapd and iphone?

CONTEXT: App, TIMESTAMP: 1593300532516, MESSAGE: undefined is not an object (evaluating ‘t[F].params’) E@/private/var/containers/Bundle/Application/3FCA2001-B114-4080-BEC6-CA1FA8346768/RNVApp.app/main.jsbundle:1147:1097
getStateForAction@/private/var/containers/Bundle/Application/3FCA2001-B114-4080-BEC6-CA1FA8346768/RNVApp.app/main.jsbundle:1147:2671
w@/private/var/containers/Bundle/Application/3FCA2001-B114-4080-BEC6-CA1FA8346768/RNVApp.app/main.jsbundle:1129:1070
map@[native code]
E@/private/var/containers/Bundle/Application/3FCA2001-B114-4080-BEC6-CA1FA8346768/RNVApp.app/main.jsbundle:1129:161

Any context on when this is happening would be appreciated. Can’t really figure out what goes wrong with just that stacktrace :confused:. What components of functions are you trying to run when it crashes?

Hi, thanks. The last thing I was working on was putting in a URL to open the browser, that worked. Then I started working on making some fields conditional on userid. then when going to the iphone to test the app, red screen. i cannot get into the app. i think i backed off the changes, to no avail.

So do I understand correctly that after the first boom the App crashes on startup everytime?

Any chance of letting us take a look at your app? Post your app id here or to me directly.

Yes, exactly. https://platform.appgyver.com/builder/applications/101025/pages/7

I assume 101025 is the app id?

I am dead in the water. I tried backing out some changes. No difference. The appgyver interface has to have a bug that allows me to break the system… :frowning:

I don’t know if this will help but you can try. In Navigation delete shortcuts in the navigation menu and then disable Navigation Menu and see if this will make your app run again without error.

I found that when you delete some pages that you point in the navigation menu, you will get an error on start.

2 Likes

THANK YOU. That worked.

1 Like