XML error with hosted web app

Hello! I deployed my website through AppGyver’s build process and cloud hosting. My website consists of a home page with repeated links that are populated using data variables sourced from the Airtable API (based on this tutorial). I then pass the page attributes (record id) onto a second page that contains more details for each entry (and populates them based on the record id).

The issue I have is that when I open my .appgyver.com web app, the link works, and I’m able to click on the individual items in the home page to be taken to the more detailed pages. However, when I copy the link to one of these detailed pages, I get this error:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

(See this link for an example)

2 Likes

Posting here because I’m hitting a similar issue.

@Mevi or @Mari (Hoping I got the right Mari there–if you’re not the AppGyver team member, please disregard!), do you friends know how to avoid this issue? I get this if a user refreshes their page–even if they’re on a page that does not require them to be authenticated.

Hello @cuyan079 @Erin_Wagner, thanks for the reports! We’re aware of this issue and it’s on the backlog for the next release with high priority. :slight_smile:

4 Likes

Hello @Mari, we are experiencing the same problem and it’s actually preventing us from deploying the app on our tablets. Is the issue going to be resolved anytime soon?

Hi @Michal_Polesny, thanks for bumping this issue up – it had unfortunately been deprioritized because of other more pressing fixes, but will be taken up again tomorrow. Thanks for your patience!

Great to hear it, @Mari . I’m sure this will be relevant for everyone, since it’s pretty common that the user would refresh a page for no apparent reason :slight_smile:

The same true for me: I’m trying to get a link to a “Privacy Policy” page (a simple one, no auth, no passed parameters) I created on the websites with AppGyver, so I can release the mobile applications to stores. But it doesn’t work, example: https://moodico.appgyverapp.com/page.Page3

Looking forward to getting this issue fixed or maybe some temporary workaround suggested. Thank you!

Hi @Mari,
Are there any updates on this? This error still occurs in our web builds when the user reloads any page (besides the app’s start page). Thanks!
Awesomeosep

Good morning/afternoon/evening/night/whatever :slight_smile:

@Mari just wanted to ping you to see if there are any estimates for when this will be addressed. I’m about to start internal testing with an eye toward external testing, and this is probably my single biggest user experience issue. Would love to have an idea of where it is on the list of priorities so I can plan accordingly.

Thanks!

@Iryna_Mostovenko , in case you still need it, there’s a workaround for being able to open a specific page that isn’t the default landing page:

On the default landing page:

  1. Create a page parameter “p”
  2. Turn on spinner by default.
  3. In the function flow, use (a) an IF function to see if the page parameter “p” equals “privacy_policy”. If so, (b) open the privacy policy page.
  4. Hide the spinner at the end of that function.

Then your privacy policy link would be https://mywebsite.com?p=privacy_policy.

1 Like

Hi @Erin_Wagner Thanks so much for sharing this! it works for me! :pray:

You guys! Refresh works now!!!

I uploaded the web app to my own server for some user testing. Much to my surprise, when a tester refreshed their browser…nothing bad happened! The page came back with all the original data! There are some layout things that got lost because those get set in the logic on the first login page, but I’ll just add that logic to all the pages and it will be perfect.

Refresh works now as long as it’s on your own domain on your own server! (I had a developer get me set up on GitHub Pages for hosting. Ping me if you want his info to help set up your own.)

Well…it mostly works. It seems to get the size of the screen wrong when refreshed (too wide). I can’t seem to fix it by manipulating my container sizes, so it seems to be a layout issue on AppGyver’s part.

Hi is this problem still in focuse, because it still doesnt work for me.
Meaning if i try opening a page other than the first page via url, this shows up

Yep, this is still a thing as of February 2022.

Is the fix still coming?

@ed_e Are you building your web app with runtime 3.4.5? The issue should not be present there any longer.

I’ll try that, thanks. The first time I built with 3.4.5 there was a build error, but I’ll try again.

Good to hear it should be fixed :+1:

Confirmed working on 3.4.5. (And now no build errors either!)

Phew!

2 Likes

As of now, there are these three options,
image

on the 4.2.12 the problem still exists


when you use a url, other that the original www.myapp.appgyverapp.com